Invalid command "ns_db ..."???

Philip Greenspun's Homepage : Philip Greenspun's Homepage Discussion Forums : 6916 : One Thread
Notify me of new responses
i've suddenly lost the ability to look at any of my pages. The error log entries state:
invalid command name "ns_db"
    while executing
"ns_db gethandle"
    invoked from within
"set db [ns_db gethandle]..."
i haven't changed database passwords, and the correct entry is in the /home/nsadmin/studentXX.ini file. i can still connect to Oracle in sqlsh. What's going on here?

-- david bessire, February 19, 2000


I've had this same kind of problem; I'm still not sure what the problem is, but restoring to an old version of my nsd.ini solved it. The error appeared to be an incorrect username/password being given to the database (according to the SQL log in the main AOLserver directory).

In looking at the non-working nsd.ini and the working one, it appears as though something is duplicating the ACS entries in it. That seems to be the only difference that looks plausibly important, but I confess I'm confused as to how it could be. I'm still puzzled, then, but I hope the restore works for you, too...

-- Greg Billock, February 28, 2000